Go Back   RCCrawler Forums > RCCrawler Brand Specific Tech > Axial AX-10 Scorpion
Loading

Notices

Thread: Problems after new build

Reply
 
LinkBack Thread Tools Display Modes
Old 10-08-2018, 03:34 PM   #1
Newbie
 
Join Date: Oct 2018
Location: norfolk
Posts: 2
Default Problems after new build

I have just upgraded my AX10 scorpion (RTR) with a bunch of bits from the internet hoping they would fit. They mostly came together but it turns out the lower links are much longer that the stock ones (139mm) and now i have an even lower ride height. Is it because the stock shocks are too short? (100mm roughly), because that seems to be the problem. I have put the lower links on the inner most mounting holes and the top of the shocks on the outer, and its basically flat now. My lowers are also binding on basically everything under compression as they are currently at full droop and inline with the skid plate.

Last edited by Sinistersdmass; 10-08-2018 at 03:51 PM.
Sinistersdmass is offline   Reply With Quote
Sponsored Links
Old 10-08-2018, 04:51 PM   #2
Newbie
 
Join Date: Sep 2018
Location: Gilbert
Posts: 9
Default Re: Problems after new build

Quote:
Originally Posted by Sinistersdmass View Post
I have just upgraded my AX10 scorpion (RTR) with a bunch of bits from the internet hoping they would fit. They mostly came together but it turns out the lower links are much longer that the stock ones (139mm) and now i have an even lower ride height. Is it because the stock shocks are too short? (100mm roughly), because that seems to be the problem. I have put the lower links on the inner most mounting holes and the top of the shocks on the outer, and its basically flat now. My lowers are also binding on basically everything under compression as they are currently at full droop and inline with the skid plate.
Add 110 mm

Sent from my SM-G955U using Tapatalk
Creepycrawly805 is offline   Reply With Quote
Old 10-09-2018, 12:33 PM   #3
Newbie
 
Join Date: Oct 2018
Location: norfolk
Posts: 2
Default Re: Problems after new build

Quote:
Originally Posted by Creepycrawly805 View Post
Add 110 mm

Sent from my SM-G955U using Tapatalk



I am surprised that will be enough as that will still be less ground clearance than stock, but fair enough. What shocks are generally recommended? I am tempted just by some cheap ones from amazon/ebay.
Sinistersdmass is offline   Reply With Quote
Old 02-05-2019, 06:55 PM   #4
Hal
Pebble Pounder
 
Join Date: Jan 2016
Location: Southampton
Posts: 188
Default Re: Problems after new build

Not sure what stock link length is. You can shorten the link some by using shorter rod ends. This may help some. A lot of people make the mistake of thinking height will make a rig crawl better. It is seldom the truth. A low center of gravity is needed. Use a longer shock and put a piece of silicone fuel line on the shaft inside the shock to limit ride height if needed. Depending on shock angle it may need a longer shock with longer links.
In the 2.2 comp scene we often lower our crawlers to make them sidehill better. It is a balance game too tall = rollover, too low = bottoming out on skid. Springs can play into this also. If you know some one with a crawler that you like the ride height on see if they will let you take some measurements. Try to copy the position of the shocks and link position as close as possible. Sometimes a mm can make all the difference in how a rig handles. Also think about shortening your new links, it's not hard. Most links are hollow if they are aluminum like Axials are. Good luck.
If you have any specific questions PM me and I will see if I can help you out. I have done a lot of research on here about 4 link geometry. It can get VERY confusing. Good luck
PS if you can post pics it is very helpful in diagnosing your problem.
Hal is offline   Reply With Quote
Reply

Tags
ax10, lower links, shocks



Problems after new build - Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems wit first build KEVLAR Axial Wraith 11 09-30-2015 11:07 PM
LCC Build Problems Please HELP!!! rockcrawler150 Team Losi Comp Crawler 5 01-11-2011 06:04 AM
Build problems! Apie Tamiya CR-01 4 09-26-2009 08:41 PM
Build Problems! Help!! lordy49 Venom Creeper 5 01-28-2009 01:13 AM
problems during build-up. silverbullet Tamiya Clod Buster 11 03-10-2006 07:14 AM
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com