Go Back   RCCrawler Forums > Scale Rigs Brand Specific Tech > Axial Wraith
Loading

Notices

Thread: My Wraith

Reply
 
LinkBack Thread Tools Display Modes
Old 05-28-2019, 09:01 PM   #1
Newbie
 
Join Date: May 2019
Location: US
Posts: 2
Default My Wraith

So my wraith started life as a spawn rtr and one of the first runs I broke a lower link, a trip to rpp and 3 days later I had some vanquish ss links in my hands. A few runs after that I blew the stock servo out and replaced it with a cheapy savox one. I got a run out of that one and it started cutting out, at the moment I thought it was because it was drawing to much power, so I got a hobby wing 1080 and that didn't do a thing. While all this was going on I collected some tires and wheels and the stock wraith body panels. I threw all of that stuff on and also bought a eco power servo. That one worked for a battery and a half then started glitching out, I got that one warrantied and threw in the new one, that one worked for a while, a about a week and a half then burned it self up. That is when I got a big ole savox and that thing is so fast it scared me the first time I turned the tires. I then stripped the tranny gears so I tore everything down and threw in some vanquish ones. At that same time I made my own battery forward tray and it made an insane difference in its crawling capabilities, it keeps the receiver box in the stock location. Just about an hour ago I finished my fastback mod so all of these pictures are fresh. The motor is definitely on its way out so any suggestions on that would be helpful. If you have any comments or suggestions let me know. I will be updating this thread every time this thing gets a new mod.(Sorry for the terrible pictures, the camera on my phone sucks)

Sent from my SM-G935P using Tapatalk

Last edited by CrawlerCam123; 05-28-2019 at 09:03 PM.
CrawlerCam123 is offline   Reply With Quote
Sponsored Links
Old 06-03-2019, 10:50 AM   #2
Newbie
 
Join Date: May 2019
Location: US
Posts: 2
Default Re: My Wraith

So I broke a front axle yesterday and I am wondering if I should go with the vanquish universal's or Axials universal's for an upgrade. If you could let me know what ones you like better that would be great, thank you.

Sent from my SM-G935P using Tapatalk
CrawlerCam123 is offline   Reply With Quote
Old 06-03-2019, 11:30 AM   #3
RCC Addict
 
Join Date: Feb 2016
Location: Santa Maria, CA
Posts: 1,186
Default Re: My Wraith

I have zero complaints about the Axial universals, been running them for several years with no issues, brushless with 3s (and for awhile 4s) even after I had clearanced them for more steering angle. They are finally getting sloppy though, so I've been weighing my options too.

That said, the Incision universals sure look like they've been beefed up as much as possible while still retaining their "drop in" replacement compatibility. I found a good pic here that shows how the size of the joint absolutely max's out the available space in the c-hub (assuming you have OEM, or Vanquish c-hubs, as these axles don't fit in some other brand s of c-hubs):
SSD C-Hub and Incision CVD’s

Now if you're talking about the Vanquish VXD axles/spool, those are slightly bigger still (and more than double the price) but they'd be the strongest of the bunch (that you mentioned... there's definitely stronger ones out there, like Dlux FBA's.)
TheLetterJ is online now   Reply With Quote
Old 06-03-2019, 11:36 AM   #4
Newbie
 
Join Date: Mar 2019
Location: St.Paul
Posts: 9
Default Re: My Wraith

Awesome, I think I am going to go with the axial ones, Thank you very much for you´re input.
CrawlerCam10 is offline   Reply With Quote
Old 06-19-2019, 02:46 PM   #5
Newbie
 
Join Date: May 2019
Location: Lumberton
Posts: 28
Default Re: My Wraith

Can you please tell me how you got those front end parts to get that Rock bumper installed on your rig? That is a 1.9 Wraith, correct? I can't find those parts or see how to configure that front end like you did to get that bumper installed. I have the same body and am trying for a similar look to this.

Thanks in advance.
Texas_Jester is offline   Reply With Quote
Old 06-19-2019, 02:51 PM   #6
Newbie
 
Join Date: May 2019
Location: Lumberton
Posts: 28
Default Re: My Wraith

My bad, I guess the Spawn already has that front end and bumper on it.
Texas_Jester is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 02:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com