Go Back   RCCrawler Forums > RCCrawler General Tech > Electronics
Loading

Notices

Thread: Rooster ESC and Spektrum receiver issue

Reply
 
LinkBack Thread Tools Display Modes
Old 02-19-2008, 06:30 AM   #1
Rock Stacker
 
Join Date: Feb 2008
Location: Charlotte
Posts: 97
Default Rooster ESC and Spektrum receiver issue

I just mounted my Rooster crawler combo yesterday and have one small issue. When I turn the switch on, the esc gives throttle to the motor for about 2 seconds until the Spektrum receiver comes on. I know it's normal for the Spektrum to need a short time to initialize, but this is the only ESC that I've seen that wants to run when the receiver is not active. I have four other RCs with Spektrum receivers, ESCs include a Novak GTB, Mamba, and Traxxas VXL - they all sit in neutral until the receiver is active.

Any thoughts? I did program the failsafe position when binding the receiver and transmitter to be about 15% brake, but that doesn't change anything.
Miller Time is offline   Reply With Quote
Sponsored Links
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com