Go Back   RCCrawler Forums > RCCrawler General Tech > Electronics
Loading

Notices

Thread: Killerbody 12 LEDS light system issues

Reply
 
LinkBack Thread Tools Display Modes
Old 06-21-2019, 07:12 PM   #1
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Killerbody 12 LEDS light system issues

Anyone have experience installing Killerbody 12 LED light system? I am trying to install this into a new Axial scxII Deadbolt. The package does not have any specific instructions just a simple diagram. I connected the system to the receiver and all I get is blinking lights and no control of steering or throttle either. I tried looking them up on the web for a more detailed instruction and a spec sheet on voltage input range but found nothing. I would like to power the lights with a 9 volt battery for the light bar. I don't really need the fancy stuff it is supposed to do. Any help would be great. Thank You.
Ragenwraith is offline   Reply With Quote
Sponsored Links
Old 06-23-2019, 05:33 PM   #2
Pebble Pounder
 
Join Date: Jan 2019
Location: Calgary
Posts: 176
Default Re: Killerbody 12 LEDS light system issues

Did you use Y cables, or just disconnect your ESC and servo and install the led controller?
Xx Losungen xX is offline   Reply With Quote
Old 06-23-2019, 08:50 PM   #3
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Re: Killerbody 12 LEDS light system issues

Quote:
Originally Posted by Xx Losungen xX View Post
Did you use Y cables, or just disconnect your ESC and servo and install the led controller?
Yes, I followed the info that came with the light controller making sure of the polarity and steering/throttle connections and all that happened was steering glitching with no throttle. Lights -all of them- just blinked. There is a disclaimer from Killerbody that says this is not compatible with all radio controller systems. I told the LHS what I was installing this in when I bought it, maybe they don't even know that it doesn't work with Axial. I thought I would reach out to the RCCrawler folks before I contact the hobby store. It might be something simple I'm not doing.

Thanks for your reply.
Ragenwraith is offline   Reply With Quote
Old 06-24-2019, 10:37 AM   #4
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Re: Killerbody 12 LEDS light system issues

Anybody ??? No one has Info about this ???
Ragenwraith is offline   Reply With Quote
Old 06-24-2019, 12:29 PM   #5
Custom RC Electronics
 
heyok's Avatar
 
Join Date: May 2007
Location: Vancouver, BC
Posts: 2,234
Default Re: Killerbody 12 LEDS light system issues

Try posting a link to the kit or at least a photo of it.
heyok is offline   Reply With Quote
Old 06-24-2019, 01:14 PM   #6
Pebble Pounder
 
Join Date: Nov 2018
Location: Mexico, Guadalajara
Posts: 139
Default Re: Killerbody 12 LEDS light system issues

I think I have the same problem I can't find the correct way to install this

Killerbody LED Light System w/ Control Box 14 LEDs for Front, Rear, Interior (3mm: 10 LEDs; 5mm: 4 LEDs) LC70

KB/48706



I couldn't find the corresponding manual either
antigacho is offline   Reply With Quote
Old 06-24-2019, 08:06 PM   #7
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Re: Killerbody 12 LEDS light system issues

I guess I'm going to give up on making this work...ANTIGACHO posted a picture of his 14 LED light kit which has a different control box than the 12 LED but has the same "Y" connectors for plugging into the radio receivers steering and throttle ports and the same plugs on the ends of the LED lights. I tried messaging Killerbody on their FB page but have not received any reply from them. This sure would have been just what I needed for my new Axial Deadbolt lights. ANTIGACHO, did you try plugging the system into your radio as per the schematic that came in the package? If so did all of the LED's flash and the steering servo glitched back and forth with no throttle when you pulled the trigger? That's what happened on mine. What kind of rig are you putting this in?

If I get a reply from Killerbody I will post again with what they tell me. Heyok, thanks for replying too...

The 12LED system is the KB #48102
Ragenwraith is offline   Reply With Quote
Old 06-26-2019, 09:30 AM   #8
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Re: Killerbody 12 LEDS light system issues

Update... I just received a message from Killerbody overnight. They are looking into my problem. Fantastic! I will keep posting the results.
Ragenwraith is offline   Reply With Quote
Old 06-28-2019, 09:51 AM   #9
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Re: Killerbody 12 LEDS light system issues

Results are in from Killerbody...I asked if the 12 LED light kit # 48102 could be powered by a 9 volt/external battery supply, the answer is "NO". I also told them I tried connecting it, as per the schematic that came in the package, to my SCXII Deadbolt stock radio...They asked if I made mistakes when I installed it...I am going to ass/u/me they do not have a clue how to support their product. I would have thought they would have offered to send a replacement light kit or at least the controller to see if the one I have is defective. The price was $10 for the 12 LED kit so I bought it at my LHS. Buyer beware is all I can say. I hope this gets out to everyone that is considering buying a Killerbody #48102 12 LED light Kit.
Ragenwraith is offline   Reply With Quote
Old 06-28-2019, 11:38 AM   #10
Pebble Pounder
 
Join Date: Jan 2019
Location: Calgary
Posts: 176
Default Re: Killerbody 12 LEDS light system issues

Did you connect it to a 9 volt battery first?
Xx Losungen xX is offline   Reply With Quote
Old 06-28-2019, 01:01 PM   #11
Rock Stacker
 
Join Date: Feb 2013
Location: Fountain Hills Arizona
Posts: 81
Default Re: Killerbody 12 LEDS light system issues

Quote:
Originally Posted by Xx Losungen xX View Post
Did you connect it to a 9 volt battery first?
No, I followed the instructions and connected it to the receiver of the Deadbolt and found it would not work. Now for the rest of the story I did connect a 9 volt battery to the light controller and got the same results, all LED's flashing (very dim) I used both leads that plug into the receiver with the 9 volt then tried one at a time nothing worked.
Ragenwraith is offline   Reply With Quote
Reply



Killerbody 12 LEDS light system issues - Similar Threads
Thread Thread Starter Forum Replies Last Post
LEDs and light buckets 7echo Electronics 9 04-07-2013 10:41 AM
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com