Go Back   RCCrawler Forums > RCCrawler General Tech > General Crawlers
Loading

Notices

Thread: Bmrc spool problems.

Reply
 
LinkBack Thread Tools Display Modes
Old 12-18-2014, 06:08 PM   #1
Rock Crawler
 
Join Date: Mar 2014
Location: Yorkville
Posts: 745
Default Bmrc spool problems.

So i have went through three in the course of a week am i the only one? but it seems i take my truck out one time and the tips of the spool where my mips go on bend or break and im not being very hard on them And im running in dirt no rocks or anything is it a problem with my set up still or the spool? its driving me crazy. i have checked the travel and everything there is ok it dosent go too far and bind or anything. is there some thing else it could be?
gunder463 is offline   Reply With Quote
Sponsored Links
Old 12-18-2014, 06:23 PM   #2
RCC Addict
 
Join Date: Feb 2014
Location: Mt. Juliet, TN
Posts: 1,031
Default Re: Bmrc spool problems.

Have you spoken to Matt at BMRC? Don't hold me to this statement but it was my understanding that he was having some quality control issues with his supplier, doesn't mean that your particular spools were part of that batch.
SteveC6R is offline   Reply With Quote
Old 12-18-2014, 06:59 PM   #3
Rock Crawler
 
Join Date: Mar 2014
Location: Yorkville
Posts: 745
Default Re: Bmrc spool problems.

Quote:
Originally Posted by SteveC6R View Post
Have you spoken to Matt at BMRC? Don't hold me to this statement but it was my understanding that he was having some quality control issues with his supplier, doesn't mean that your particular spools were part of that batch.
have not spoken with him will have to shoot him a email.
gunder463 is offline   Reply With Quote
Old 12-18-2014, 07:08 PM   #4
RCC Addict
 
Join Date: Feb 2014
Location: Mt. Juliet, TN
Posts: 1,031
Default Re: Bmrc spool problems.

I noticed you said "setup still", can you elaborate on your setup and what rig you have?
SteveC6R is offline   Reply With Quote
Reply



Bmrc spool problems. - Similar Threads
Thread Thread Starter Forum Replies Last Post
traxxas slash 4x4 spool or no spool? Oregon crawler Formula Offroad 12 03-17-2012 03:02 PM
Problems problems problems hope it's worth it in the end TJcreeperJEEP Venom Creeper 9 12-22-2009 05:54 PM
Just got a LCC, still confused on the spool problems. Mad-Man Team Losi Comp Crawler 11 11-18-2009 01:55 AM
BMRC BJ Build BlueMonster Tamiya TLT Crawlers 9 03-10-2008 01:06 PM
trac gear spool?? anyone tried these or had problems yukon635 Tamiya TLT Crawlers 0 06-05-2007 04:54 PM
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com