Go Back   RCCrawler Forums > RCCrawler Brand Specific Tech > Heritage Crawlers > Venom Creeper
Loading

Notices

Thread: Official venom factory support thread

Reply
 
LinkBack Thread Tools Display Modes
Old 01-27-2009, 02:50 PM   #61
I wanna be Dave
 
Join Date: Jul 2008
Location: appleton
Posts: 2,067
Default

Thanks for the quick reply cant wait to get this running again looking forward to driving it and comparing the differenceslooking forward to Paul getting in touch with me .............Chris
my black pin on the cvd was broke right out of the box the silver pin is mia after the axle end broke off

Last edited by kasper; 01-27-2009 at 02:55 PM.
kasper is offline   Reply With Quote
Sponsored Links
Old 01-27-2009, 03:58 PM   #62
Quarry Creeper
 
Join Date: Nov 2008
Location: St George
Posts: 318
Default

Quote:
Originally Posted by CRAWLINGAROUND View Post
That could be and we are seeing a few more cases of that failure so we are tracking that down now. The pins should shear as a safety feature so you dont break more expensive parts but just not a glance! lol If you could find some pins at your LHS that would be better for the time being because I cant be sure of the inventory we have at the moment.

You broke the black pins or the silver pins? The silver go in the center driveline and the black pins go in the VCD's.

Chris

They are the black pins. Paul is sending me a few, I am also trying a couple different things.
1\4elliptic toy is offline   Reply With Quote
Old 01-29-2009, 02:10 PM   #63
Newbie
 
Join Date: Jan 2009
Location: flag
Posts: 4
Default Great costumer service!

Just wanted to say how good the service was.
I bought a creeper, a few small parts were missing .
Called up Jason , had the new parts in a few days...Thanks for your good costumer service!

Rob
flagazcruiser is offline   Reply With Quote
Old 01-29-2009, 03:02 PM   #64
Pebble Pounder
 
Join Date: Jul 2007
Location: deva - romania
Posts: 154
Default

great to hear that the customers support are good...but can we have a statment from them, where to find out when all thos nasty problems are gone????......when the bad axeles stock are finished, when all the bits are secured packed......becouse beeing a non US customer will be like hell to wait for the kit, wait for the missing parts...wait for replacement for broken parts...so Venom guys, can you tell us something ???
cornel4web is offline   Reply With Quote
Old 01-30-2009, 10:15 AM   #65
Pebble Pounder
 
Join Date: Dec 2007
Location: Northwest
Posts: 181
Default

For our international customers we are including a pair of extra wheel axles free of charge. Its too hard to say when all the problems will go away. All we can say is that these issues have been addressed and for the upcoming produciton runs we expect that it will be better.
There are also some improvements being made to the kit itself that will begin to appear in the next produciton runs.
That being said the kit will evolve and improve as quickly as possible and we will take care of any problems with your kit through our Customer Service Department. We have at least 3 people at any one time monitoring the forums and assisting online as needed.

Thanks for your support,

Chris
CRAWLINGAROUND is offline   Reply With Quote
Old 02-01-2009, 09:33 PM   #66
I wanna be Dave
 
Join Date: May 2006
Location: akron
Posts: 4,054
Default

any one have a issue with the CVD's one of mine was to large to fit threw the bearings.. I turned it down enough to get the bearings on but I dont think they will be easy to get off..

other then that everything went together pretty easy hope to have it up and running by the weekend
sloppy is offline   Reply With Quote
Old 02-01-2009, 10:22 PM   #67
Newbie
 
Join Date: Feb 2009
Location: Indian Rocks
Posts: 14
Default CVD's

Quote:
Originally Posted by sloppy View Post
any one have a issue with the CVD's one of mine was to large to fit threw the bearings.. I turned it down enough to get the bearings on but I dont think they will be easy to get off..

other then that everything went together pretty easy hope to have it up and running by the weekend
One of mine wasn't drilled for the pin.
catcrawler is offline   Reply With Quote
Old 02-01-2009, 10:38 PM   #68
Newbie
 
Join Date: Feb 2009
Location: Indian Rocks
Posts: 14
Default CVD's an tire

Called about the hole not drilled in the CVD, told no parts in stock, so I drilled it. Not sure how long will last, but have got to run.

As for the tire was a bad mold I guess, is septurated in the seam in center of tire. On teck call said would send new tire.:-P

Only other problem have had pins in driveshafts keep coming loose, fall out.
I think that is from good runs.
catcrawler is offline   Reply With Quote
Old 02-02-2009, 04:30 PM   #69
Newbie
 
Join Date: Jan 2009
Location: flag
Posts: 4
Default

Quote:
Originally Posted by catcrawler View Post
Called about the hole not drilled in the CVD, told no parts in stock, so I drilled it. Not sure how long will last, but have got to run.

As for the tire was a bad mold I guess, is septurated in the seam in center of tire. On teck call said would send new tire.:-P

Only other problem have had pins in driveshafts keep coming loose, fall out.
I think that is from good runs.
There was a post in here about using a bit of heat shrink around the drive shaft at the pin to stop them from coming out.
Seems like a great idea!
flagazcruiser is offline   Reply With Quote
Old 02-02-2009, 06:45 PM   #70
Newbie
 
Join Date: Dec 2008
Location: Spokane
Posts: 20
Default

Make sure you apply loctite. When building these rigs, just like when I build helis, I clean each bolt with alcohol before applying any thread lock, that will ensure that the thread lock does work. This cleans off any machining fluid from when they make the fasteners.

--Paul
VGI CS
Kootenai Krawle is offline   Reply With Quote
Old 02-03-2009, 02:43 PM   #71
Quarry Creeper
 
Join Date: Sep 2005
Location: Creeping in the Dark!!!
Posts: 349
Default

I just want to say that your customer service is top noch & dave in cs has been a wonderful help!! Thanks for everything venom!!!
sniders1975 is offline   Reply With Quote
Old 02-03-2009, 03:05 PM   #72
Pebble Pounder
 
Join Date: Dec 2007
Location: Northwest
Posts: 181
Default

Cool thanks for the support and for trying something new.

Chris
CRAWLINGAROUND is offline   Reply With Quote
Old 02-04-2009, 02:53 AM   #73
Newbie
 
Join Date: Feb 2009
Location: China
Posts: 8
Smile

Hi Chris,

I am new to this forum. I live outside the US and would want to have the venom creeper. Do you have Venom official dealer in China so that when there are problems arising on parts (as what other owner experience), we can have replacements? Hope to hear from you very soon.
moonski is offline   Reply With Quote
Old 02-04-2009, 06:49 AM   #74
Newbie
 
Join Date: Jan 2009
Location: Rio Rancho
Posts: 45
Default

Ordered my creeper a couple of days ago. Should be here on Friday.
zerimar is offline   Reply With Quote
Old 02-04-2009, 08:57 AM   #75
Quarry Creeper
 
Join Date: Dec 2008
Location: Gardnerville
Posts: 272
Default

Anybody have a problem with the diffs unlocking
by themselves? I have not run mine much prolly
around 1/2 hr time. About 3 times for about 10 minutes
each time in the back yard. I am still waiting on BEC
to show up. Anyway about 5 minutes into run the diffs
unlock.I am not running servos or the diff lock kit. The
diff lock mechanism does not seem to move very much
front or rear. Kind of a PITA to get them to move. I am
thinking I might have to tear it down and inspect. They
worked fine when I first put it together.
ktmkurt is offline   Reply With Quote
Old 02-04-2009, 05:41 PM   #76
Newbie
 
Join Date: Feb 2009
Location: Colorado Springs
Posts: 20
Talking

hey chris, i just ordered a creeper and was wondering if you knew if the over heat treated parts were still in circulation, and if some kits were still missing pieces. im kind of new to crawling not to rc's in general and i chose the creeper over all the other cralwers on the market. i also have a dig unit on order so when they come out i will get one. i have read over and over how your costumer service is exceptional and i hope if i am in the same situation that i will recieve the same kind of help. i really appreciate any info you have and im really looking forward to getting my creeper and hitting the rocks!!!
CO_Crawler is offline   Reply With Quote
Old 02-04-2009, 07:08 PM   #77
Quarry Creeper
 
Join Date: Sep 2005
Location: Creeping in the Dark!!!
Posts: 349
Default

Any one else having problems with the pin that holds the axel shaft to the outer shaft in the cvd I have shered 2 of them so far & have not been doing any hardcore crawling!
sniders1975 is offline   Reply With Quote
Old 02-04-2009, 08:03 PM   #78
Newbie
 
Join Date: Feb 2009
Location: Colorado Springs
Posts: 20
Default

hi chris, i just purchased a creeper and i was wondering if you if there were still problems with kits missing parts, and the issues with the over heat treated parts. i chose the creeper over all the other crawlers on the market. i hope that if i experience any problems i will get the same help that others have recieved, thanks in advance chris for any info you have!
CO_Crawler is offline   Reply With Quote
Old 02-05-2009, 09:04 AM   #79
Quarry Creeper
 
Join Date: Nov 2008
Location: St George
Posts: 318
Default

Quote:
Originally Posted by ktmkurt View Post
Anybody have a problem with the diffs unlocking
by themselves? I have not run mine much prolly
around 1/2 hr time. About 3 times for about 10 minutes
each time in the back yard. I am still waiting on BEC
to show up. Anyway about 5 minutes into run the diffs
unlock.I am not running servos or the diff lock kit. The
diff lock mechanism does not seem to move very much
front or rear. Kind of a PITA to get them to move. I am
thinking I might have to tear it down and inspect. They
worked fine when I first put it together.
Yep, I just posted a super cheap, quick ,easy fix for it in a thread called "locker issue solved" What you will find is the red ring has moved back and twisted a small peice of the plastic case out into the way so it cant lock back in, take a knife and shave it flat again and do the mod I have and it wont do it again
1\4elliptic toy is offline   Reply With Quote
Old 02-05-2009, 09:12 AM   #80
Quarry Creeper
 
Join Date: Nov 2008
Location: St George
Posts: 318
Default

Quote:
Originally Posted by sniders1975 View Post
Any one else having problems with the pin that holds the axel shaft to the outer shaft in the cvd I have shered 2 of them so far & have not been doing any hardcore crawling!
Yes, I have destroyed a few of them, You can go down to you local hardware store and ask for "music wire" for piano's they have a size (.78 ) I think. it comes in like 3 foot lengths, cut it a hair long with side cutters, tap the end on your grinder to flatten out the cut, slide it in and tighten the set screw, (it fits amazingly well) then I put a small ring of 1/2 heat shrink tubing around it to keep it from possibly coming out if the set screw gets loose. You can make about 100 pins from 1 length of wire for about a $1.00 and they are plenty strong, I have some replacement pins from venom but I am still runnning the music wire in one rear shaft with no problems.
1\4elliptic toy is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com