Go Back   RCCrawler Forums > Regional > Midwest > Wisconsin
Loading

Notices

Thread: Official WiRCRC Chit Chat

Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2010, 07:13 AM   #181
I wanna be Dave
 
Join Date: Jul 2008
Location: appleton
Posts: 2,067
Default

No sir i do not all i have is the one set in the bronco wished i could help.
kasper is offline   Reply With Quote
Sponsored Links
Old 04-06-2010, 10:41 AM   #182
Rock Crawler
 
Join Date: Feb 2009
Location: Wrightstown
Posts: 960
Default

Kasper, if you still wanna sell those blue rovers bring 'em along on Sunday, I'll take 'em off your hands.
Super is offline   Reply With Quote
Old 04-06-2010, 01:30 PM   #183
RCC Addict
 
Join Date: Jul 2008
Location: Fox Valley WI
Posts: 1,691
Default

Quote:
Originally Posted by kasper View Post
No sir i do not all i have is the one set in the bronco wished i could help.
You suck! .

I guess I'll have to do some online searching.
TrailDawg362 is offline   Reply With Quote
Old 04-06-2010, 01:37 PM   #184
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

Anyne wana trade there ax10 for an lcc

Been thinking about selling it and buying the ax10 kit, just noone has them instock.
Satan6907 is offline   Reply With Quote
Old 04-06-2010, 08:53 PM   #185
Pebble Pounder
 
Join Date: Oct 2008
Location: Appletown
Posts: 130
Default

Quote:
Originally Posted by satan6907 View Post
anyne wana trade there ax10 for an lcc

been thinking about selling it and buying the ax10 kit, just noone has them instock.
eeeee bbbbaaaayyyyy
Stinkyy is offline   Reply With Quote
Old 04-06-2010, 09:24 PM   #186
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

Quote:
Originally Posted by Stinkyy View Post
eeeee bbbbaaaayyyyy
I looked there



DAMN BEC!!

put the sidewinder and the bec in my blitz along with my nice servo, was working good on the bench, set it on the floor to test the setup on the esc and the dam bec died, same thing that happened to my other one.

Hook the battery to it and nothing, plug in the castle link and the green led comes on but the castle link dont see it.

I haven't sent my other one in yet so it looks like castle is getting 2 less then 3 week old becs with the same issues.
Satan6907 is offline   Reply With Quote
Old 04-07-2010, 02:43 AM   #187
Rock Crawler
 
Join Date: Mar 2008
Location: 920 Valley of the Fox
Posts: 768
Default

Quote:
Originally Posted by Stinkyy View Post
eeeee bbbbaaaayyyyy
Why not try to trade it off on here?
R/CMaxximus5.0 is offline   Reply With Quote
Old 04-07-2010, 02:45 AM   #188
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

Quote:
Originally Posted by R/CMaxximus5.0 View Post
Why not try to trade it off on here?
Cant see the market place on here yet, says i only got 23 posts.

If only the post in this section would count.
Satan6907 is offline   Reply With Quote
Old 04-07-2010, 06:42 AM   #189
I wanna be Dave
 
Join Date: Jul 2008
Location: appleton
Posts: 2,067
Default

antbody game to head down to oshkosh thursday evening around 6 ish..
kasper is offline   Reply With Quote
Old 04-08-2010, 01:36 PM   #190
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

Well the way it looks is my comp rig has to go bye bye for now.

Real trucks needs title and registration and I just dont have the funds to get the comper the eletrics it needs to perform, Unless I sell my Dingo, but the LCC dont have enough batts to last more then 1 hour right now.
Satan6907 is offline   Reply With Quote
Old 04-08-2010, 01:45 PM   #191
RCC Addict
 
Join Date: Jul 2008
Location: Fox Valley WI
Posts: 1,691
Default

One hour of run-time is more than enough to comp with .

Ask around, one of us might have what you need even if it's just for the day. Between all of us, we prolly have enough spare parts to build half a dozen trucks
TrailDawg362 is offline   Reply With Quote
Old 04-08-2010, 01:49 PM   #192
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

well i was looking at a 400oz servo at 6v( Hitec 7590- only good one I found) My 235 just aint enough.

A goat 3s or a MMP with a 18.5. The 55t gets to warm in the lcc and stalls out easy.
Satan6907 is offline   Reply With Quote
Old 04-08-2010, 02:14 PM   #193
RCC Addict
 
Join Date: Jul 2008
Location: Fox Valley WI
Posts: 1,691
Default

Thats more than I have in my parts stash. I wonder how a stock 27 turn would work in your rig (just for the day?). As for the servo, thats better than I have in my comper . I say just run it, and have some fun. It's just grown men playing with toy trucks anyway, don't take it too seriously .
TrailDawg362 is offline   Reply With Quote
Old 04-08-2010, 02:26 PM   #194
Rock Crawler
 
Join Date: Feb 2009
Location: Milwaukee
Posts: 609
Default

Quote:
Originally Posted by Satan6907 View Post
but the LCC dont have enough batts to last more then 1 hour right now.
That's plenty for a comp.

Quote:
Originally Posted by TrailDawg362 View Post
I say just run it, and have some fun. It's just grown men playing with toy trucks anyway, don't take it too seriously .
Exactly!! You probally will end up w/1st.
T-buck is offline   Reply With Quote
Old 04-08-2010, 02:27 PM   #195
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

it also dont help both of my castle becs are dead
Satan6907 is offline   Reply With Quote
Old 04-08-2010, 02:40 PM   #196
RCC Addict
 
Join Date: Jul 2008
Location: Fox Valley WI
Posts: 1,691
Default

Yeah, that does suck. How about running a 4 cell alkaline battery pack for the rx? That would give you 6 volts to the servo, a cheap and effective short term fix? Not sure if that would give you the juice you'd need though. A 5 cell nimh would prolly be better...just a thought.

That might cure your stalling issue also.

**You might need to disconnect the red (power) wire from the esc to the rx so that you're running directly from the rx battery**

Last edited by TrailDawg362; 04-08-2010 at 03:51 PM.
TrailDawg362 is offline   Reply With Quote
Old 04-08-2010, 04:07 PM   #197
I wanna be Dave
 
Join Date: Jul 2008
Location: appleton
Posts: 2,067
Default

I might have one or two laying in my drawer your welcome to use them and see how well she works let me know and i will get them charged up for ya thats what i used for the xtm with the dual servos worked fine for that.Let me know walter there yours
kasper is offline   Reply With Quote
Old 04-08-2010, 04:20 PM   #198
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

Thanks Kasper.

Ima see if I can either sell/trade the Dakota or barrow some of the registration money from a friend.

I guess for now I would need to find a brushed setup that will give me a lil more wheel speed and hopefully not heat up as much.

If anyone has some el cheapo brushed motors that work LMK, I know some people say the 12t titan works out in the LCC sometimes.
Satan6907 is offline   Reply With Quote
Old 04-08-2010, 04:32 PM   #199
I wanna be Dave
 
Join Date: Jul 2008
Location: appleton
Posts: 2,067
Default

I should have 6 or more laying in the motor drawer all brushed someone may as well use them but heres what i know about the losi 4 cell lipo is what you need to turn them axles but i have motors.

Heres a thought i work till seven on friday and 2 on saturday bring your stuff and we should be able to get you rollin just a idea if interested

Last edited by kasper; 04-08-2010 at 04:35 PM.
kasper is offline   Reply With Quote
Old 04-08-2010, 04:36 PM   #200
Rock Stacker
 
Join Date: Oct 2009
Location: Brillion
Posts: 95
Default

Quote:
Originally Posted by kasper View Post
I should have 6 or more laying in the motor drawer all brushed someone may as well use them but heres what i know about the losi 4 cell lipo is what you need to turn them axles but i have motors.

Cool.


I have 3s. I have thought about the Novak Goat 3s but for the price I can get the MMP with more setup options, easier to setup and run up to 6s lipo.

Once I get my hands ont he MMP I would like to start with a 18.5 on 3s and go higher in the s range is needed or a lower kv motor.
Satan6907 is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com