Go Back   RCCrawler Forums > RCCrawler Brand Specific Tech > Heritage Crawlers > Losi Micro-Rock Crawler
Loading

Notices

Thread: Servo Issues

Reply
 
LinkBack Thread Tools Display Modes
Old 12-22-2010, 04:30 PM   #1
Newbie
 
Join Date: Dec 2010
Location: Greenfield
Posts: 42
Default Servo Issues

I'm having the problem of my servo deciding to change where center is while crawling. Stock servo with no spring. I've only run, at most, 10 charges through the truck and this has happened 3 times. Is this servo just plain junk???
evilunclefred is offline   Reply With Quote
Sponsored Links
Old 12-22-2010, 05:08 PM   #2
Pebble Pounder
 
Join Date: Feb 2010
Location: Canada
Posts: 195
Default

Search for the problem here,your not the only one with it then search for "servo guide"...
orangeplug is offline   Reply With Quote
Old 12-22-2010, 05:24 PM   #3
Newbie
 
Join Date: Dec 2010
Location: Greenfield
Posts: 42
Default

Hitec HS-65MG Is this a good replacement???
evilunclefred is offline   Reply With Quote
Old 12-22-2010, 08:04 PM   #4
rik
RCC Addict
 
Join Date: Oct 2009
Location: In the mancave...
Posts: 1,038
Default

Quote:
Originally Posted by evilunclefred View Post
Is this servo just plain junk???
YES.


Quote:
Originally Posted by evilunclefred View Post
Hitec HS-65MG Is this a good replacement???
yup,

Quote:
Search for the problem here,your not the only one with it then search for "servo guide"...
what he said.
rik is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 03:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com