Go Back   RCCrawler Forums > Scale Rigs Brand Specific Tech > Axial Brand Scale Rock Crawlers > Axial SCX10 II
Loading

Notices

Thread: missing parts from kit

Reply
 
LinkBack Thread Tools Display Modes
Old 07-14-2016, 03:31 PM   #1
Quarry Creeper
 
Join Date: Jun 2012
Location: Next to you
Posts: 438
Default missing parts from kit

So i got a new kit and it was missing the rear lockout also drive shaft coupler wasn't even threaded. I also noticed that one shock binds even off truck. Has anyone else had problems with the plastic splitting?
Diablo666 is offline   Reply With Quote
Sponsored Links
Old 07-14-2016, 08:36 PM   #2
Rock Stacker
 
Join Date: Jun 2013
Location: Wendell
Posts: 64
Default Re: missing parts from kit

Ive herd of missing parts, my LHS recieved the kit i bought 6-29 and i had no issues. The shocks did bind on mine. I cleaned the piston up as best as i could to get the parts tree plastic off. They move freely with oil in, but if it sits overnight it sticks untill the suspension is cycled once and it is fine while running. Also i had no issues with the plastic at all. Give axial a call they will make it right.
blknslvr is offline   Reply With Quote
Old 07-15-2016, 08:44 PM   #3
Quarry Creeper
 
Join Date: Dec 2008
Location: Missouri
Posts: 320
Default Re: missing parts from kit

I was missing one shock hoop and my shocks were the same before sanding the pistons to fit. Smooth as butter now. Typical for the icon shocks in my experience though.

Sent from my SM-G900V using Tapatalk
scott83 is offline   Reply With Quote
Old 07-16-2016, 12:45 PM   #4
Rock Stacker
 
Join Date: Nov 2015
Location: PHX
Posts: 57
Default Re: missing parts from kit

I was missing bearings and some screws.

Also, the instruction manual is wrong in more than a couple spots.

Guess that's what you get with an early release product.
yellowdatsun is offline   Reply With Quote
Reply



missing parts from kit - Similar Threads
Thread Thread Starter Forum Replies Last Post
tf2 kit missing parts!!!!!!!!!!!!! ak907killa RC4WD Trail Finder 2 60 04-24-2013 11:34 PM
Missing parts from sealed Wraith kit wheelstoo Axial Wraith 4 01-02-2012 09:31 PM
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com