Go Back   RCCrawler Forums > RCCrawler Brand Specific Tech > Heritage Crawlers > Losi Mini-Rock Crawler
Loading

Notices

Thread: Locker/Spool failures..

Reply
 
LinkBack Thread Tools Display Modes
Old 02-03-2009, 12:41 PM   #1
Pebble Pounder
 
Join Date: Dec 2008
Location: The Dirty Dirty, A-Town, ATL, The A, Hot-Lana, ATLANTA GEORGIA
Posts: 115
Default Locker/Spool failures..

Ok, so I'm sure if you've played with your crawler a little bit you've upgraded to metal lockers. When my front failed I removed the whole carrier assembly and found that the heads of all the screws on one side of the carrier had broken off leaving the threaded portion of the screw stuck in the carrier/ring gear. Anyone else experience this?
mrdrinksalil is offline   Reply With Quote
Sponsored Links
Old 02-03-2009, 01:39 PM   #2
RCC Addict
 
Join Date: Feb 2008
Location: Hiatus..sutiaH
Posts: 1,620
Default

Quote:
Originally Posted by mrdrinksalil View Post
Ok, so I'm sure if you've played with your crawler a little bit you've upgraded to metal lockers. When my front failed I removed the whole carrier assembly and found that the heads of all the screws on one side of the carrier had broken off leaving the threaded portion of the screw stuck in the carrier/ring gear. Anyone else experience this?
Yup, I had two broken on each diff?! Many have had this problem. Contact Losi or Rich here and they can help you. Heck, I still need to do that for myself. I can use mine, but there are broken screws in both.
O.C.D. is offline   Reply With Quote
Old 02-03-2009, 02:10 PM   #3
Rock Stacker
 
Join Date: Jan 2009
Location: Columbia
Posts: 65
Default

i broke 2 on the front and 1 on the back
MR. MAX is offline   Reply With Quote
Old 02-03-2009, 02:26 PM   #4
Rock Crawler
 
Join Date: May 2007
Location: Glendora
Posts: 571
Default

Just upgraded my diffs. Can you you guys keep us posted on Losi's solution to this? Thanks.
difflocker is offline   Reply With Quote
Old 02-08-2009, 06:55 PM   #5
RcBros Hobbies
 
RcBro's Avatar
 
Join Date: Nov 2005
Location: Oregon
Posts: 4,646
Default

Just took mine apart and two of mine were broken, curious if this is why my ring and pinion failed on me as well.
RcBro is offline   Reply With Quote
Old 04-17-2009, 08:13 AM   #6
pup
Quarry Creeper
 
Join Date: May 2006
Location: Snake Run, IN
Posts: 268
Default

Any updates to this? I broke my front on the finals course at ECC and ordered the lockers when we got back. Just took it apart and ALL 4 screws on 1 side are broken.

Any tips to fix this? I have a comp on Sunday and want to run this thing. Has anyone tried drilling them out to 3mm? Does not look like there is much material there for that but I REALLY want this thing fixed.


EDIT: After looking at it some more, has anyone tried running these with NO screws on 1 side? It looks like with a metal locker it MAY work for a while until I can get replacement parts. I have a PM in to Rich hopefully he will have an answer for me.

Last edited by pup; 04-17-2009 at 08:32 AM.
pup is offline   Reply With Quote
Old 04-17-2009, 11:16 AM   #7
Rock Crawler
 
Join Date: Feb 2009
Location: Surprise, Az
Posts: 848
Default

My front is epoxied together and working fine since Feb, they should stay together without screws unless the case fails though.
Failedabortion is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.
Copyright 2004-2014 RCCrawler.com